Works Fine Rated 4 out of 5 stars

You have to alter the XPI so that the version of FF goes up... the reason it doesn't work for most is because of that. It seems that there is no more support for this add-on, unless you do it yourself.