Rated 5 out of 5 stars

I wish there was an update too. Shannon you need to update this, or publish the source. It's an amazing addon. I've been using it for years now.

Rated 5 out of 5 stars

This is the reason why I still did not update my browser. There is no worth substitute to this addon for Firefox 4.

This user has a previous review of this add-on.

Love it. Need it for Firefox 4 Rated 5 out of 5 stars

Love this add on. It's a great accessibility feature.

I dunno enuff about how it works to make it work with firefox 4 :(

Rated 5 out of 5 stars

We need it for Firefox 4 :(

Rated 5 out of 5 stars

can you make available the source code to recompile it for Firefox 4?

Rated 5 out of 5 stars

http://rapidshare.com/files/352211509/speakit-for-firefox-3.x.xpi

works like a charm

Speakit for v3.6 to v3.9.9 Rated 5 out of 5 stars

this version of speak it work for firefox versions 3.6 up to 3.9.9
it works great just be sure to uninstall the current one before adding
Enjoy
http://rapidshare.com/files/352211509/speakit-for-firefox-3.x.xpi

Mod the xpi to 3.6 Rated 3 out of 5 stars

1. change filename.xpi to filename.zip.
2. open zip file.
3. drag install.rdf to desktop.
4. open with notepad, change maxversion to 3.6 or whatever you need.
5. save, close, replace zipped install.rdf with your new one.
6. change .zip back to .xpi
7. open the edited xpi with FF, install.
Works same as ever.

up date it Rated 1 out of 5 stars

Hi
This is Palash SarkerThe speak It program is may be wellbut its very old version.so you should up date it soonthank you.

Rated 1 out of 5 stars

TalkingClipboard.com Firefox extension is much better than this, and you don't need to make any accounts anywhere, and that is also free.

Rated 5 out of 5 stars

Download speakit-for-firefox-3.xpi
Open it using 7zip or whatever compression tool works
extract the install.rdf file
open the rdf with notepad or text editor
change the maxVersion to anything greater than or equal to what Firefox currently is.

3.9.9.*

Rated 5 out of 5 stars

Thanks FF, thanks Speak It for good design.
It work when we change the Max Version of FF to 3.5
http://ifile.it/a07x4nt

Speak It for FF 3.5 Rated 5 out of 5 stars

Luckily, It's work for FF 3.5 if we just change the max version :"> ! Thanks Firefox 3.5, thanks Speak IT
http://ifile.it/a07x4nt

Rated 5 out of 5 stars

For the people who are looking for the firefox 3 version, ive change the maxVersion to include ff3 here http://www.zshare.net/download/61961631b4f4f192/

Rated 5 out of 5 stars

For the people who are looking for the firefox 3 version, ive change the maxVersion to include ff3 here http://www.zshare.net/download/61961631b4f4f192/

Rated 5 out of 5 stars

Thanks, monmonja for altering the maxversion. Before I would use the the Override Compatibility add-on by SpaceMan(++), but this is much easier.

Anyone know where shannon lee went to?

Rated 5 out of 5 stars

For the people who are looking for the firefox 3 version, ive change the maxVersion to include ff3 here
http://almondmendoza.com/2008/12/07/speakit-for-firefox-3/

Rated 5 out of 5 stars

Firefox 3 should offer a TTS add on which works as well as 'Speak It' did for Firefox 2. I have attempted to switch to Firefox 3 twice in the last year but always go back to version 2 for the 'Speak It' TTS.

Not for FF3 Rated 1 out of 5 stars

To previous commnet of Vanhout on October 23, 2008 "Make the Firefox extensions available for version 3." Your advise has not worked for me. Well, it works, but you can not stop it or pause it.

extensions available for version 3. Rated 4 out of 5 stars

Make the Firefox extensions available for version 3.
Open the control panel by typing about:config in the addresses bar of the navigator.
Create a new Boolean entry named extensions.checkCompatibility and put the value to false

Permitir las extensiones Firefox para la versión 3.
Abrir el panel de configuración escribiendo about:config en la linea de direcciones del navegador.
Crear una nueva entrada Boolean con el nombre extensions.checkCompatibility y poner su valor a false

Rendre les extensions Firefox disponibles pour la version 3.
Ouvrir le panneau de configuration en tapant about:config dans la barre d'adresse du navigateur
Créer une nouvelle entrée booléenne nommée extensions.checkCompatibility et positionner sa valeur à false