Not compatible with FF 3.5.6. Rated 2 out of 5 stars

Not compatible with FF 3.5.6.
Any workarounds?

This review is for a previous version of the add-on (1.3.0). 

Please, recheck

The compatibility information has been set to 3.6.* since I uploaded the new 1.3.0 version of this add-on, so you shouldn't find any problem to use it with Firefox 3.5.6 (I for one have instaled it in Firefox 3.5.6 without any problem).

Even so, I've extended the compatibility information to Firefox 3.7, Thunderbird 3.1 and SeaMonkey 2.1 nightlies. Could you recheck, please?