works with ff 3.5.3 Rated 3 out of 5 stars

although it says it does work with ff 3.5+ the button for download is not available (only older versions). But downloading and installing from the author's website works.

This review is for a previous version of the add-on (5.5).