Error Rated 1 out of 5 stars

Firefox could not install the file at

https://addons.mozilla.org/firefox/downloads/file/61124/-1.3.3.1-fx.xpi?src=version-history

because: Unexpected installation error
Review the Error Console log for more details.
-203


That's what I get when I try to install, and why I have to give it ONE star, rather than the FIVE I'd have liked to give it after a successful install...

...any chance of that being possible sometime in the near future?

This review is for a previous version of the add-on (1.3.3.1).