For me it works with FF4 Rated 5 out of 5 stars

After disabling the compatibility check it worked just fine for me.. using FF 4.0 and Smart Bookmarks Bar 1.4.3