Rated 5 out of 5 stars

In order to work in FF4 just follow those 3 steps:
1) download the .xpi file
2) open it with a zip-like program (I used 7zip)
3) edit install.rdf, line 16: replace 3.6blabla with 4.1