Rated 4 out of 5 stars

YAY its working in 3.5. I had only just installed it and began using it for a couple of weeks before upgrading, and it wasnt compatible.

Thanks for updating it, as I had found it very useful.