Rated 5 out of 5 stars

I installed an add-on called "compatibility reporter" and "site launcher" works fine with FF Ver.6
All you need to know.

This review is for a previous version of the add-on (1.6.4).