Rated 3 out of 5 stars

I second Vlada011`s comment. Please upgrade to be compatible with Firefox 4. (On your on time, of course)

This review is for a previous version of the add-on (0.9.0).  This user has a previous review of this add-on.