Rated 5 out of 5 stars

I, too, had problems with this in FF17. Had to go back to 15.0.1 to get it to work right as Mozilla recommended NOT going back to 16.

Still giving it 5 stars because I know it will be fixed soon.

This review is for a previous version of the add-on (2.83.2.1-signed).  This user has a previous review of this add-on.