Can't install on TB 2.0.0.14 Rated 1 out of 5 stars

It's not compatible with the latest thunderbird 2.0.0.14. Can you update it?

This review is for a previous version of the add-on (0.4.0.5.20070419).