Firefox 12 :-( Rated 5 out of 5 stars

does also not work with FF12 as with FF11
and no the versions on googlecode are also completly outdated and will not work in FF11/FF12 packages of Fedora (x86_64)

This review is for a previous version of the add-on (1.3).  This user has a previous review of this add-on.