PLEASE UPDATE!!! Rated 4 out of 5 stars

Hi. I love this add-on. Unfortunately it stop to work properly with FF 20.0 and up. Please, update it.
Thanks.

This review is for a previous version of the add-on (0.9.5.9.1-signed.1-signed).