Need update Rated 4 out of 5 stars

Not compatible eith FF5 :(

This review is for a previous version of the add-on (1.1.1). 

Compability updated, it should work fine now.