Working with FF4 :-) Rated 5 out of 5 stars

Tested the latest Shelve and it is working fine with FF4.0b8 and
I have attached a 4.* shelve.xpi for ease of use here: It is based on a shelve 1.22 from 2010.12.12.
Get ShelveLogger here:

This review is for a previous version of the add-on (1.22).  This user has 2 previous reviews of this add-on.