not with FF8 Rated 1 out of 5 stars

Doesn't work with FF8 but then nothing does.. When will Mozilla learn to stop messing everything up with their unfinished "Rapid Releases".. I have uninstalled more AddOns & Programs because they are not compatible with FF upgrades (?).. Also, FF might work a little better if they would dump the FB api that hangs up everything.. Today 12/6/11 FF crashed again so no Internet up until now **sigh**.. Fingers crossed.

This user has 2 previous reviews of this add-on.