Rated 4 out of 5 stars

Good, but when I tried to install it on FF3, it came up incompatible. Wazzup?