Rated 1 out of 5 stars

V 2.4 Not compatible with firefox 15
Faulty plugin

V 2.4 Incompatible avec Firefox V.15
Plantages systématiques