Great tool and helpful folks too Rated 5 out of 5 stars

I was disappointed when Firefox told me SEOQuake was not compatible with FF4, so sent a message to SEOQuake support, and they responded, telling me to remove the plugin and re-install. Now it is working with Firefox 4 again.

This review is for a previous version of the add-on (2.7.1).