Hi Rated 5 out of 5 stars

Hi, with which firefox version will it work. im using firefox7 but it does not work. any ideas?

This review is for a previous version of the add-on (1.3.2). 

The latest version of our add on has been tested in version 1.5 to the latest beta version of Firefox (v24.0).

Thanks,
Andrew M