Good Add-On Rated 4 out of 5 stars

This is a good add-on, but it could be improved. I live in California and here there are waaay to many earthquakes that are 2.5+. It seems to activate nearly every time I use my browser. It would be nice if you could set the minimum earthquake. I am not interested in any earthquake around where I live unless it is 5 or higher.

This review is for a previous version of the add-on (1.3.1). 

Thanks for the comment. This option will be available in version 2.0 coming soon.