Rated 5 out of 5 stars

Nice addon.

Thank you for Firefox 4.0 Beta compatibility (even latest trunk is compatible).

This review is for a previous version of the add-on (1.36.1-signed).