Update to FF 3.5 Rated 4 out of 5 stars

The author Ian McKellar made the sources available here :

http://github.com/ianloic/searchery/tree/master

Maybe a good soul could work on it to make it compatible with FF 3.5 ? Actually, I personally didn't update to 3.5 because this extension doesn't work with this version.