Rated 5 out of 5 stars

It doesn't compatible on Firefox 3.5.*

This review is for a previous version of the add-on (0.31).