Still seems to work with FF20 Rated 4 out of 5 stars

As someone has told it here, using "Disable Add-on Compatibility Checks" add-on makes it work, and even on FF ver. 20. Tested on a Mac.

Hope the developper comes back, or at least makes the code open source so that someone else could continue with it.

This user has a previous review of this add-on.