Firefox 3.5 Compatibility Rated 5 out of 5 stars

Yeah, I'm having the same problem. I wrote a plug-in for Scrapbook but he doesn't respond.

Fox, to make it compatible with any version do the following:
-Download scrapbook- by right-clicking the download link and saving it somewhere;
-Add ".zip" to the filename so you have
-Extract the contents of the file with a zip manager.
-In the root of the resulting folder, find "install.rdf".
-Open it in a text editor.
-At line 44, find 3.0.*
-This is the maximum Firefox version the extension will work with.
-Change the value "3.0.*" to "3.5.*" or higher. I used "4.0.*"
Now re-compress the contents of with your new install.rdf.
Rename to scrapbook-
You can now either install it by double-clicking the .xpi or selecting File/Open File... in Firefox and browsing to your new extension.

This process works with any extension. I have used it a few times before and have just done the same with Scrapbook so it's running in 3.5. The only reason it would fail is if some core functionality that the extension relies on changes. Now you never need to wait for an update again.

This review is for a previous version of the add-on (