Rated 5 out of 5 stars

I can not live without this add-on, but SaveURI will not work under FF3.6!
I changed 3.5.* to 3.6.* in .XPI file, Add-on was installed without any problem, but not worked at all. Any body have any solution?

This review is for a previous version of the add-on (0.3.2).  This user has a previous review of this add-on.