Sage ++ Rated 3 out of 5 stars

Firefox 5.6.7 user can use Sage ++(but need Add-on Compatibility Reporter):

http://blog-imgs-30-origin.fc2.com/h/i/m/himag/sagepp-higmmersedition-install.html

This review is for a previous version of the add-on (1.4.11).