Warning: Still Vulnerable Rated 2 out of 5 stars

Why AMO brought back this add-on outside of the sandbox? AFAIK the latest version 1.4.5 is still vulnerable now. Please read the following article for the detail.

http://himag.blog26.fc2.com/blog-entry-325.html?lang=en
(JavaScript is required for English translation)

This review is for a previous version of the add-on (1.4.5).