Not compatible/working with Firefox 3.6 Rated 1 out of 5 stars

Plugin does not work with Firefox 3.6.
Please update it to make it work again.
Thanks in advance! :-)