Outdated for a long time! Rated 1 out of 5 stars

Malfunctioning since Fx 3.6. No desired result obtained in the test case.

Rated 1 out of 5 stars

Neither SafeHistory 0.8 nor 0.9 (http://crypto.stanford.edu/SafeHistory/stanford-safehistory-0.9.xpi) are working for me with FF 3.6.13 after making the trick to allow them to be installed on FF 3.x versions. Both are breaking browser history by ceasing to add items to history list, or at least not showing.
Update is needed for FF 3.6.x and upper 3.x verions!
(It probably works fine for FF 3.x versions lower than 3.6.x but I haven't checked. FF 4.x and upper versions doesn't need SafeHistory feature at all).

Also SafeHistory have exactly the same flaw for FF versions > 2.x, with Cookies section in Options->Privacy, than SafeCache addon. You can find a description and a fix for it in my reviews https://addons.mozilla.org/en-us/firefox/addon/safecache/reviews/user:5280876

Rated 5 out of 5 stars

This plugin is just amazing!
And it works under FF 3.6 with the following trick: Download the .xpi file with Internet Explorer:
https://addons.mozilla.org/en-US/firefox/downloads/latest/1502/addon-1502-latest.xpi?src=addondetail
Rename it to .zip and open the zip-File. Delete the folder "META-INF" and open the file "install.rdf" with a text editor. Change the line 2.0.0.* to 3.6.*
Save the file and put it in the .zip archiv. Rename the .zip file to .xpi again and open it with Firefox. It asks you to install the addon and you are done.
The addon works smoothly with FF 3.6.3 by the way ;)
Also try the 2nd addon from this developer called "SafeCache", same method like here to get it working with FF 3.6.*

Rated 5 out of 5 stars

This plugin is just amazing!
And it works under FF 3.6 with the following trick: Download the .xpi file with Internet Explorer:
https://addons.mozilla.org/en-US/firefox/downloads/latest/1502/addon-1502-latest.xpi?src=addondetail
Rename it to .zip and open the zip-File. Delete the folder "META-INF" and open the file "install.rdf" with a text editor. Change the line 2.0.0.* to 3.6.*
Save the file and put it in the .zip archiv. Rename the .zip file to .xpi again and open it with Firefox. It asks you to install the addon and you are done.
The addon works smoothly with FF 3.6.3 by the way ;)
Also try the 2nd addon from this developer called "SafeCache", same method like here to get it working with FF 3.6.*

Not compatible/working with Firefox 3.6 Rated 1 out of 5 stars

Plugin does not work with Firefox 3.6.
Please update it to make it work again.
Thanks in advance! :-)

Rated 1 out of 5 stars

Doesn't work well, and interferes with other add-ons. Then, when you try to uninstall it, it doesn't. It tells you that it will uninstall the next time Firefox starts up, but it stays there.

firefox 3 rc1 Rated 5 out of 5 stars

Interferes with the history file in Firefox 3 RC1. If you're thinking of trying to force an install with this addon wait until its updated. I would also avoid using this addons cousin Safecache with Firefox 3 RC1. This is a great addon I know that it works fine in previous versions of Firefox. So I still give it 5 stars.

History Menu Gone!!!!! Rated 2 out of 5 stars

When this addon is installed, when you click 'History' in the menu-bar, the Recent History Menu will be gone. Uninstall to bring it back.

Rated 5 out of 5 stars

Great extension, never had any problems. Our admins include this on all our computers.

Breaks location bar Rated 4 out of 5 stars

The idea behind this extension is interesting, but it at the moment it breaks \"Sorting By Most Visited\" for the URL location bar. Instead it seems to sort by Last Visited or something entirely else.

I Like it. Rated 4 out of 5 stars

Explains itself, gotta stay safe.