Rated 4 out of 5 stars

This theme works perfectly on Linux ...
Firefox 3.1 (3.5?) Beta 3
Ubuntu 8.10
extensions.checkCompatibility = false

This review is for a previous version of the add-on (1.3.1).