"Rikaichan could not be installed because it is not compatible with Firefox 15.0" Rated 1 out of 5 stars

Read title. Please release new update soon!

This review is for a previous version of the add-on (2.05.1-signed).