1.09 is missing; use 1.08 to install something Rated 3 out of 5 stars

Version 1.09 is corrupt. Use version 1.08 -- it installs.

This review is for a previous version of the add-on (1.09).