doesn't work anymore Rated 4 out of 5 stars

I love this ext but it is no longer working for me... error says it is no longer compatible with Firefox 2.0.0.14 and only works with 1.4? Strange and I can't get in touch with the developer as the homepage listed here is not a valid address :(