works in FF3 I think Rated 4 out of 5 stars

I've tested in FF3 and it works for me, you just have to mod the xpi file via "six steps to heaven" routine:

Props to Gogo77 (amended):
1. Save latest version of .xpi file to desktop
2. Rename *.xpi to *.zip
3. Open zip in e.g. Winzip and open install.rdf in edit mode
4. Replace 1.4* by 3.* in Mozilla Firefox section.
5. Save file and rename zip archive back to .xpi
6. Open .xpi file in Firefox, will install no problem


I have Tab mix Plus installed in single window mode so I don't get affected by the issues outlined above. This tool is ace!