Rated 5 out of 5 stars

Good idea, this basic feature was truly missing.
I confirm that it works with firefox 6.0.2 (just edit the .xpi file, see on the internet how to make addons compatible, it's pretty easy).

Good work :)