compatibility issues with firefox 3.6.2 Rated 1 out of 5 stars

oh hell...nothing seems to be compatible with firefox 3.6.2

i really messed myself up by downloading the update. not recommended.

This review is for a previous version of the add-on (1.3.7). 

3.6.2

Just tested ImageShack and several FTP sites with 3.6.2. Everything is working for me. If you've got an issue please report the details to the CodePlex site.