Rated 4 out of 5 stars

This works in SeaMonkey 2.21, so why not list it as compatible with it? I had to bump up the max version in the install file to get it to install.

This review is for a previous version of the add-on (0.8.16.1-signed).