Rated 5 out of 5 stars

I wish this worked on OSX. Qute was the main reason I was stuck on FF 3.6 until this weekend, when the end of support forced me to upgrade. I might abandon FF altogether without it.