works on ff10 Rated 5 out of 5 stars

I agree it works perfectly for FF10 nightlies after doing the version number tweak.
And I was always on the people's side that say that compatibility checking nonsense is nothing but WINDOW-DRESSING.
Because it benefits no one; it just creates obstacles you need to bypass by artificial means (i. e. version hacking and friends)

Mr. Avila would just "update" his extension by raising max version to 10 or 11, and couldn't you do that yourself?
So you see - I've never seen this compatibility checking stuff being of any practical use. But because of a handful of stubborn conservative developer nerds, it will probably never happen that these checks ever get removed for good.