Rated 3 out of 5 stars

Need FireFox 4 compability, please.