Rated 5 out of 5 stars

If you guys wanted it for v4.0 to the following -> download xpi file (with different browser), then OPEN it (don't extract, just open) with archive extracting software (WinRAR, WinZip, IZArc). There's a file called install.rdf, double click to open it, find line "<em:maxVersion>" and change value from 3.6.* to 4.*.*. Then close the xpi archive file, it will ask for update the archive with updated install.rdf -> click yes