Work perfect in Nightly Rated 5 out of 5 stars

The website reports it is not compatible with Firefox 9,0a1 (nighly build) but when you install it anyway it works perfectly!