Not compatible with 3.6.10? Rated 1 out of 5 stars

Although the description says it is compatible up to version 4.something, when I installed it on 3.6.10 I got a message that it is incompatible. I'll file a bug report.