Version 2009.07.03 is not compatible with FF 3.5.1 Rated 5 out of 5 stars

Version 2009.07.03 is not compatible with FF 3.5.1. FF is not not letting me install. Please update the latest version.

This review is for a previous version of the add-on (2009.07.03).