Simple yet essential Rated 5 out of 5 stars

This one add-on is all that's keeping me from upgrading to FF 3.5 betas. Don't worry about the "Open Browser Proxy Settings” button bug - it's not necessary for basic functionality. Please update!

This review is for a previous version of the add-on (2009.03.28).