3.0.3 Compatability - Which is it? Rated 3 out of 5 stars

Does Provider work with 3.0.3 - some say yes, others say no. When I clicked to download the update, I got a message saying that provider and the nightly updater will not work with 3.0.3. What I have is working, I don't want to mess it up. Any thoughts?

This review is for a previous version of the add-on (0.6b1).