Rated 5 out of 5 stars

WoW !!!
This add-on need be come standard FIREFOX 7.0 !
it have to come as Firefox 7.0 PLEASE MOZILLA !!!

This review is for a previous version of the add-on (13.1-signed.1-signed).